本页面仅适用于 Prism Windows 版本。在 Mac 上无法使用“对象链接与嵌入”(OLE)功能。我们真希望它能支持。
粘贴对象、链接或图片的区别
有三种方法可以复制 Prism 图表或布局,并将其粘贴到许多 Windows 程序中,包括 Word 或 PowerPoint。
将图表或布局作为 Prism 对象粘贴:
Prism 将粘贴图表的图像,以及创建该图表(或布局)所需的所有数据、分析和图形设置的副本。
在其他程序中双击该对象,即可在 Prism 中进行编辑,您可以在 Prism 中编辑数据、更改分析设置以及设置图表格式。退出 Prism 后,修改后的图表将显示在 Word 中。
嵌入的优势在于,Word 或 PowerPoint 文件是完整的,其中包含 Prism 的数据和设置。一个缺点是这会使 Word 文件体积增大。 另一个缺点(对某些人而言)是,这意味着您的数据可能存储在多个位置。如果您发现数据输入有误,则需要编辑所有副本。也有人将此视为一种优势——一种备份数据的方式。
一个 Prism 对象仅包含与您粘贴的图表(或布局)相关联的数据表和结果。Prism 项目的其他部分不会被包含在内。
此功能仅限 Windows 系统,Prism Mac 版本不支持。
考虑在 Word 中创建绘图画布
在 Word(但不包括 PowerPoint)中,您可以转到“插入”>“形状”,然后选择“新建绘图画布”。该“画布”是一个可组合图像的区域。您可以在其中粘贴 Prism 图表、添加文本、导入图像、插入形状和公式…… 如果您直接在页面上单独插入这些元素,它们会与流动文本相互缠绕。将它们放入画布中,既能保持元素的整体性,又能使其远离流动文本,并允许您控制它们之间的排列方式。了解更多。
将图表或布局粘贴为图片
一张图片或许胜过千言万语,但它不允许您编辑数据、更改分析选项或重新格式化图表。当您双击已粘贴的图片时,无法在 Prism 中对其进行编辑。相反,系统会打开一个通用图形或照片编辑器。
这种方法的一个优点(对某些人而言)是,您发送文件的人将无法查看您的数据或编辑您的图表。由于无需存储数据和设置,这种方法不会占用太多磁盘空间。
将图表或布局粘贴为链接
Prism 可以同时粘贴图片和指向 Prism 文件的链接。双击后,Prism 将自动启动并打开链接的 Prism 项目。随后,您可以在 Prism 中编辑数据、分析设置或图表。退出时,修改后的图表将在 Word 或 PowerPoint 中自动更新。
与“粘贴对象”相比,此方法的一个优点是您的 Word 或 PowerPoint 文件体积会更小。另一个优点(对某些用户而言)是它将数据集中存放在一处,便于编辑。 其缺点在于,该链接实际上只是指向特定位置下某个特定名称文件的链接。如果链接的文件已被删除、重命名或移动,您将无法对其进行编辑。如果您将 Word 或 PowerPoint 文件转移到另一台计算机上,除非该链接文件也被一并转移,否则您将无法打开它。
此功能仅限Windows系统,Prism Mac版不支持。
插入对象
如果您将 Prism 对象插入到 Word 或 PowerPoint 中,将嵌入整个 Prism 项目。相比之下,当您将图表作为对象粘贴时,仅会嵌入与该图表关联的数据和结果。
从其他程序的“插入”菜单中选择“插入对象”命令(或在 Office 2007 中,位于“插入”选项卡的右侧)。选择“从文件创建对象”,然后选择您的 Prism 文件。
此方法的优势在于它包含了整个 Prism 项目。如果您将文档发送给同事并希望包含所有支持细节,这可能会很有用。
此方法仅适用于 Windows 系统,Prism Mac 版本不支持此操作。
如何选择粘贴对象、链接或图片
一键发送至 PowerPoint 或 Word 的按钮
Prism“首选项”对话框中的“发送至 MS Office”选项卡中的设置,将决定 Prism 的“一键发送”按钮是发送对象、链接还是图片。
复制和粘贴
当您复制图表(或布局)时,Prism 会将所有必要信息放入剪贴板,以便粘贴程序可以选择粘贴图片、对象还是链接图片。 Microsoft Word、Excel 以及旧版本的 PowerPoint 会粘贴嵌入式对象。PowerPoint 2007 和 2010 则有所不同。默认情况下,它们会粘贴图片。若要覆盖此默认设置,请打开剪贴板菜单,选择“选择性粘贴”,然后选择粘贴 Prism 对象。
复制与“选择性粘贴”
与其直接粘贴(并让程序自行选择),不如使用“选择性粘贴”命令,这样您就可以选择要粘贴的格式。 在大多数程序中,“选择性粘贴”是“编辑”菜单下的选项。而在 Office 2007 和 2010 中,它位于功能区“开始”选项卡左侧的“粘贴”菜单下。
“选择性粘贴”对话框允许您选择粘贴对象(“GraphPad Prism 8 项目对象”)或图片(“增强型元文件”)。您还可以粘贴位图,这在希望该 Word 或 PowerPoint 文档在 Mac 上显示效果良好时可能会派上用场。
如果您选中此选项以粘贴链接,滚动列表中将不会显示任何选项。如果您从未命名的 Prism 项目中复制图表,则此选项将不可用,因为建立链接要求 Prism 文件必须有名称。
EMF+、EMF(旧版)还是 WMF?
Windows 支持三种用于通过矢量和字体描述图像的类似格式。WMF(Windows 元文件)格式较旧。EMF+(增强元文件)格式较新,理论上略胜一筹。 Prism 还可以使用旧版本的 EMF。实际上,某种格式对某些程序效果更好,而另一种格式对其他程序效果更好。这似乎无法预测。
请在“首选项”对话框的“文件与打印机”选项卡底部,选择要放入剪贴板的格式(以及向 PowerPoint 发送图表时使用的格式)。如果粘贴后的图表显示异常,请尝试使用另一种格式。
编辑嵌入 PowerPoint 或 Word 中的 Prism 对象
要编辑嵌入在 PowerPoint 或 Word 中的 Prism 对象,只需双击该对象即可。
如果您的计算机上安装了多个版本的 Prism,Windows 会自动选择要启动的版本(即创建该对象时所用的版本)。但您可以覆盖此设置:在 PowerPoint 中右键单击 Prism 对象,选择“Prism 对象”命令,然后从子菜单中选择“转换”,并选择您希望用于打开该对象的 Prism 版本。
使用不同版本的 Prism 打开 Prism 对象
当您双击嵌入在 Word 或 PowerPoint(或其他位置)中的 Prism 对象时会发生什么?如果创建该对象的 Prism 版本已安装在您的计算机上,则该版本的 Prism 将打开它。如果该版本未安装,则较新版本的 Prism 将打开该文件。 但如果该对象是用 Prism 7 创建的,而计算机上只有 Prism 6,则该对象将无法打开。此时您会看到一条说明此情况的消息。
在 Prism 中编辑后,更新 Word 或 PowerPoint 中的对象
在 Prism 中编辑完对象后,您需要将这些更改推送到包含该对象的程序中,通常是 Word 或 PowerPoint。有三种方法可以实现:
•完全关闭 Prism。要执行此操作,请点击 Prism 窗口右上角的“X”按钮,或打开“文件”菜单并选择“退出”。
•关闭包含该对象的 Prism “文件”,但不要完全关闭 Prism。为此,请点击 Prism 窗口右上角较小的“X”按钮(位于完全关闭 Prism 的按钮正下方)。或者打开“文件”菜单并选择“关闭并返回至……”。
•关闭包含该对象的 Prism“文件”,但不要更新 PowerPoint 或 Word。忽略您的更改,并保持 Word 或 PowerPoint 的当前状态。要执行此操作,请打开“文件”菜单并选择“关闭但不更新...”
•在 Prism 中保持对象打开的同时,更新 PowerPoint 或 Word 中的对象。要执行此操作,请点击 Prism 中的“保存”按钮,或使用 Control-S 键盘快捷键。